using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+56|56)?(?:\s?\(?9\)?[\s.-]?(\d{4})[\s.-]?(\d{4}))$";
string input = @"912345678
+56912345678
56912345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}