$re = '/^(?:\+56|56)?(?:\s?\(?9\)?[\s.-]?(\d{4})[\s.-]?(\d{4}))$/m';
$str = '912345678
+56912345678
56912345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);