using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(15620450000|VS|00)(\d{8})";
string input = @"1562045000012345678
VS12345678
0012345678
12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}