const regex = /(15620450000|VS|00)(\d{8})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(15620450000|VS|00)(\\d{8})', 'gm')
const str = `1562045000012345678
VS12345678
0012345678
12345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}