package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(15620450000|VS|00)(\d{8})`)
var str = `1562045000012345678
VS12345678
0012345678
12345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}