import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(10(\\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))){2}|172\\.(1[6-9]|2\\d|3[0-2])(\\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5])))|192\\.168(\\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))))$";
final String string = "10.17.0\n"
+ "172.16.26\n"
+ "192.168.2\n"
+ "1.1.1.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}