const regex = /^(10(\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))){2}|172\.(1[6-9]|2\d|3[0-2])(\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5])))|192\.168(\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(10(\\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))){2}|172\\.(1[6-9]|2\\d|3[0-2])(\\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5])))|192\\.168(\\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))))$', 'gm')
const str = `10.17.0
172.16.26
192.168.2
1.1.1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}