$re = '/^(10(\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))){2}|172\.(1[6-9]|2\d|3[0-2])(\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5])))|192\.168(\.(1?[[:digit:]][[:digit:]]?|2([0-4][[:digit:]]|5[0-5]))))$/m';
$str = '10.17.0
172.16.26
192.168.2
1.1.1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);