$re = '/.*Function=\"([^\"]*).*/';
$str = '[1] ID=Gfo_R000001;Source=ENST00000513418;Function="SMAD5";
[2] ID=Gfo_R000002;Source=ENSTGUT00000017468;Function="CENPA";
[3] ID=Gfo_R000003;Source=ENSGALT00000028134;Function="C1QL4";
[4] ID=Gfo_R000004;Source=ENSTGUT00000015300;Function="";
[5] ID=Gfo_R000005;Source=ENSTGUT00000019268;Function="";
[6] ID=Gfo_R000006;Source=ENSTGUT00000019035;Function="";
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;