package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(ge\\\\pt02\\\\kr02)`)
var str = `ge\\pt02\\kr02_20180824\\kr02_2018091log\\0010796ab5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}