$re = '/^(ge\\\\\\\\pt02\\\\\\\\kr02)/m';
$str = 'ge\\\\pt02\\\\kr02_20180824\\\\kr02_2018091log\\\\0010796ab5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);