// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(ge\\\\pt02\\\\kr02)").unwrap();
let string = "ge\\\\pt02\\\\kr02_20180824\\\\kr02_2018091log\\\\0010796ab5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}