using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!as\s|:\s|import\s|<|\|\s))DevExpress";
string input = @"// Examples of lines to ignore
import DevExpress from '../bundles/dx.all';
ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;
editorOptions: <DevExpress.ui.dxDataGridOptions>{
| DevExpress.ui.dxFormSimpleItem[]
// DevExpress
// Examples of lines to find
export type Options = DevExpress.viz.dxRangeSelectorOptions;
DevExpress.ui.notify('', '', '');
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}