import re
regex = re.compile(r"((?<!as\s|:\s|import\s|<|\|\s))DevExpress", flags=re.DOTALL)
test_str = ("// Examples of lines to ignore\n"
"import DevExpress from '../bundles/dx.all';\n"
"ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;\n"
"editorOptions: <DevExpress.ui.dxDataGridOptions>{\n"
"| DevExpress.ui.dxFormSimpleItem[]\n"
"// DevExpress\n\n"
"// Examples of lines to find\n"
"export type Options = DevExpress.viz.dxRangeSelectorOptions;\n"
"DevExpress.ui.notify('', '', '');\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")