re = /((?<!as\s|:\s|import\s|<|\|\s))DevExpress/
str = '// Examples of lines to ignore
import DevExpress from \'../bundles/dx.all\';
ExchangeSyncServiceContainer: DevExpress.ui.dxTabPanel;
editorOptions: <DevExpress.ui.dxDataGridOptions>{
| DevExpress.ui.dxFormSimpleItem[]
// DevExpress
// Examples of lines to find
export type Options = DevExpress.viz.dxRangeSelectorOptions;
DevExpress.ui.notify(\'\', \'\', \'\');
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end