# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/step.+\s+script: \".*blr\/(.*).py\"\s+.*\s+args: \[([\"\w\W\s]+?)\]\n/\1, \2/gm;t' <<< "step1:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/BQT.py\"
skip: 0
args: [\"testbed\"]
step2:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"
skip: 0
args: [\"testbed\", \"dcinit\"]
step3:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_upgrade.py\"
skip: 0
args: [\"testbed\", \"upgrade\"]
step4:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/Apply_Policy.py\"
skip: 0
args: [\"testbed\"]
step5:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_checks.py\"
skip: 0
args: [\"testbed\"]
step6:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/delete_device.py\"
skip: 0
args: [\"testbed\", \"dcinit\"]
step7:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"
skip: 0
args: [\"testbed\", \"dcinit\"]
"