// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)step.+\s+script: \".*blr/(.*).py\"\s+.*\s+args: \[([\"\w\W\s]+?)\]\n"#).unwrap();
let string = "step1:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/BQT.py\"
skip: 0
args: [\"testbed\"]
step2:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"
skip: 0
args: [\"testbed\", \"dcinit\"]
step3:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_upgrade.py\"
skip: 0
args: [\"testbed\", \"upgrade\"]
step4:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/Apply_Policy.py\"
skip: 0
args: [\"testbed\"]
step5:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_checks.py\"
skip: 0
args: [\"testbed\"]
step6:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/delete_device.py\"
skip: 0
args: [\"testbed\", \"dcinit\"]
step7:
script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"
skip: 0
args: [\"testbed\", \"dcinit\"]
";
let substitution = "\\1, \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}