using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z](?:\.|[a-z]*)(?: [A-Z](?:\.|[a-z]*))+$";
string input = @"John Doe
John D.
John D. D.
John D. D.
John D. D.
John D.oe
J. Doe
J. D.
John DDoe
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}