$re = '/^[A-Z](?:\.|[a-z]*)(?: [A-Z](?:\.|[a-z]*))+$/m';
$str = 'John Doe
John D.
John D. D.
John D. D.
John D. D.
John D.oe
J. Doe
J. D.
John DDoe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);