re = /^[A-Z](?:\.|[a-z]*)(?: [A-Z](?:\.|[a-z]*))+$/m
str = 'John Doe
John D.
John D. D.
John D. D.
John D. D.
John D.oe
J. Doe
J. D.
John DDoe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end