package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^+@]+@\S+$`)
var str = `abc@xyz.com
abc123@xyz.com
abc.def@xyz.com
abc+123@xyz.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}