$re = '~^[^+@]+@\S+$~m';
$str = 'abc@xyz.com
abc123@xyz.com
abc.def@xyz.com
abc+123@xyz.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);