using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<tenant>[^\\]+)\]\ (?P<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3}); (?P<thread>[^;]+); \[(?P<level>[^\]]+)\]; (?P<component>[^;]+); (?P<message>.+)";
string input = @"[iablue.zucchettianalyticslab.cloud]* 2025-02-26 01:37:37,612; MantenanceTimer-0; [DEBUG]; SSOManager; pulizia della mappa dei token gia' utilizzati";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}