package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?P<tenant>[^\\]+)\]\ (?P<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3}); (?P<thread>[^;]+); \[(?P<level>[^\]]+)\]; (?P<component>[^;]+); (?P<message>.+)`)
var str = `[iablue.zucchettianalyticslab.cloud]* 2025-02-26 01:37:37,612; MantenanceTimer-0; [DEBUG]; SSOManager; pulizia della mappa dei token gia' utilizzati`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}