# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?P<tenant>[^\\]+)\]\ (?P<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3}); (?P<thread>[^;]+); \[(?P<level>[^\]]+)\]; (?P<component>[^;]+); (?P<message>.+)"
test_str = "[iablue.zucchettianalyticslab.cloud]* 2025-02-26 01:37:37,612; MantenanceTimer-0; [DEBUG]; SSOManager; pulizia della mappa dei token gia' utilizzati"
matches = re.search(regex, test_str, re.UNICODE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.