use strict;
my $str = '400k
400.2k
4m
500000
500.
500.k
4.2.k
.3k
4...k
500k
500.
5.k';
my $regex = qr/^\d+(?:\.$|\.\d+)?[KkMm]?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}