// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:\.$|\.\d+)?[KkMm]?$").unwrap();
let string = "400k
400.2k
4m
500000
500.
500.k
4.2.k
.3k
4...k
500k
500.
5.k";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}