#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(?si)^((\s?pol)|(\s?polegadas)|"|''|\x60|'|´|”)?\s?(([4-5])((\.|\,)([0-9])+)?)$"
Local $sString = ""5.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")