const regex = new RegExp('(?si)^((\\s?pol)|(\\s?polegadas)|"|\\'\\'|\\x60|\\'|´|”)?\\s?(([4-5])((\\.|\\,)([0-9])+)?)$', 'si')
const str = `"5.2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}