using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?si)^((\s?pol)|(\s?polegadas)|""|''|\x60|'|´|”)?\s?(([4-5])((\.|\,)([0-9])+)?)$";
string input = @"""5.2";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}