using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"interface (\S+)(?s).*?access-session port-control force-authorized";
string input = @"interface GigabitEthernet1/0/44
access-session port-control auto
!
interface GigabitEthernet1/0/45
access-session port-control force-authorized
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}