re = /interface (\S+)(?s).*?access-session port-control force-authorized/i
str = 'interface GigabitEthernet1/0/44
access-session port-control auto
!
interface GigabitEthernet1/0/45
access-session port-control force-authorized
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end