import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "interface (\\S+)(?s).*?access-session port-control force-authorized";
final String string = "interface GigabitEthernet1/0/44 \n"
+ "access-session port-control auto \n"
+ "!\n"
+ "interface GigabitEthernet1/0/45 \n"
+ "access-session port-control force-authorized \n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}