# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ +(?= )|radio edit|radio ice remix//gmi;t' <<< "Текст примерно такой приходит. Киркоров & Пугачева radio edit
или box box nighet"