$re = '/ +(?= )|radio edit|radio ice remix/mi';
$str = 'Текст примерно такой приходит. Киркоров & Пугачева radio edit
или box box nighet';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;