use strict;
my $str = 'Текст примерно такой приходит. Киркоров & Пугачева radio edit
или box box nighet';
my $regex = qr/ +(?= )|radio edit|radio ice remix/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";