package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(name=\".*?\")\s*(value=\".*?\")`)
var str = `'<input type="hidden" name="mode" value="<?=$modeValue?>"/>'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}