$re = '/(name=\".*?\")\s*(value=\".*?\")/';
$str = '\'<input type="hidden" name="mode" value="<?=$modeValue?>"/>\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);