re = /(name=\".*?\")\s*(value=\".*?\")/
str = '\'<input type="hidden" name="mode" value="<?=$modeValue?>"/>\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end