using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((next\s(week\s)?(on\s)?)|(week\s(from|after)\s))
\K((Mon|Tue(s)?|Wed(nes|s)?|Thu(rs|r)?|Fri|Sat(ur)?|Sun))(day|d)?";
string input = @"blah next week on Mon blah ";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}