$re = '/((next\s(week\s)?(on\s)?)|(week\s(from|after)\s))
\K((Mon|Tue(s)?|Wed(nes|s)?|Thu(rs|r)?|Fri|Sat(ur)?|Sun))(day|d)?/x';
$str = 'blah next week on Mon blah ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);