import re
regex = re.compile(r"""
((next\s(week\s)?(on\s)?)|(week\s(from|after)\s))
\K((Mon|Tue(s)?|Wed(nes|s)?|Thu(rs|r)?|Fri|Sat(ur)?|Sun))(day|d)?
""", flags=re.VERBOSE)
test_str = "blah next week on Mon blah "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")