const regex = /^(?:[^;\n]*;){3}\s+(?P<command>.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^;\\n]*;){3}\\s+(?P<command>.+)', '')
const str = `Apr 27 10:54:48 shane-Dell-System-Inspiron-N4110 sudo: shane : TTY=pts/2 ; PWD=/home/shane ; USER=root ; COMMAND=/bin/systemctl status --no-pager vdi-broker-manager-3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}