re = /^(?:[^;\n]*;){3}\s+(?P<command>.+)/
str = 'Apr 27 10:54:48 shane-Dell-System-Inspiron-N4110 sudo: shane : TTY=pts/2 ; PWD=/home/shane ; USER=root ; COMMAND=/bin/systemctl status --no-pager vdi-broker-manager-3
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end