using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)(-dirty)?$";
string input = @"git-commit-id-plugin-debugging-0.0.2-8-gf5af67c-dirty
git-commit-id-plugin-debugging-0.0.2-9-gcad3d4a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}