use strict;
my $str = 'git-commit-id-plugin-debugging-0.0.2-8-gf5af67c-dirty
git-commit-id-plugin-debugging-0.0.2-9-gcad3d4a
';
my $regex = qr/^(.*?)(-dirty)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}