$re = '/^(.*?)(-dirty)?$/m';
$str = 'git-commit-id-plugin-debugging-0.0.2-8-gf5af67c-dirty
git-commit-id-plugin-debugging-0.0.2-9-gcad3d4a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);