import re
regex = re.compile(r"[a-z]++(?<!lag|pctrange|max)", flags=re.MULTILINE)
test_str = "lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")