const regex = /\A[\r\n]+|[\r\n]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A[\\r\\n]+|[\\r\\n]+$', 'gm')
const str = `
z
h
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);