use strict;
my $str = '
z
h
';
my $regex = qr/\A[\r\n]+|[\r\n]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";